[Up]常用資訊

[重點文章] 重點文章 [重點文章] 重點文章

2017年11月22日 星期三

test 2

test 2



#!/bin/bash
dsflkds;lfks sdlfk;salkfd
 
#!/bin/bash
X=3
Y=4
empty_string=""
if [ $X -lt $Y ]  # is $X less than $Y ?
then
  echo "\$X=${X}, which is smaller than \$Y=${Y}"
fi
 
if [ -n "$empty_string" ]; then
  echo "empty string is non_empty"
fi
 
if [ -e "${HOME}/.fvwmrc" ]; then             # test to see if ~/.fvwmrc exists
  echo "you have a .fvwmrc file"
  if [ -L "${HOME}/.fvwmrc" ]; then       # is it a symlink ?
      echo "it's a symbolic link"
  elif [ -f "${HOME}/.fvwmrc" ]; then     # is it a regular file ?
      echo "it's a regular file"
  fi
else
  echo "you have no .fvwmrc file"
fi

2017年11月7日 星期二

Debina 8 Bind DNS forward 到 F5 GTM 不work

我在Debian 8 的 Bind DNS(BIND 9.10.3-P4-Debian)當forward 到 F5-DNS 時候竟然無法查詢 F5-DNS 上的紀錄

tcpdump 紀錄有看到紀錄但卻沒有回到 client 上


client 卻看到

調整
 /etc/bind/named.conf.options 由

變成



重啟bind dns 

/etc/init.d/bind9 restart

確認查詢正常


搞定收工




2017年10月23日 星期一

測試

test


when RULE_INIT {
 set static::mseconds 10000
 set static::maxdupreq 10
}
when CLIENT_ACCEPTED {
 set dup_req 0
 set last_req “”
}
when HTTP_REQUEST {
 if { $last_req equals “” } {
  set last_req [HTTP::uri] set dup_req 0
  }
 elseif { $last_req == [HTTP::uri] } {
  incr dup_req
  after $static::mseconds { if {$dup_req > 0} {incr dup_req -1} }
  if { $dup_req > $static::maxdupreq } {
   log “Killing suspected Mirai at [IP::client_addr]”
   TCP::respond “HTTP/1.0\r\n200 OK\r\nLocation: http\r\n\r\n”
   TCP::close
   }
  }
 else {
 set dup_req 0
 }
}

2017年10月19日 星期四

使用 curl 在windows 測試下載速度

使用 curl 在windows 測試下載速度 由於需要統計 網站 下載速度 使用了一下 curl 來測試,做了一個簡單的bat 方便自己統計。 當然請先安裝 curl 程式 (請自行google安裝方式) Bat Script 如下:
############################ bat script start ##################################
@ECHO off
ECHO *** URL Scan Start. ***
rem 時間戳記
set CURRENT_DATE=%date:~-4,4%-%date:~-10,2%-%date:~-7,2%
set CURRENT_TIME=%time:~0,2%%time:~3,2%
echo %CURRENT_DATE%-%CURRENT_TIME%

rem echo %date:~-4,4%%date:~-7,2%%date:~-10,2%

set startTime=%time%
set command=C:\curl -o /dev/null -s -w
set var="\n DNS Resolve: %%{time_namelookup}\n Client -> Server: %%{time_connect}\n Server Respon: %%{time_starttransfer}\n Total time: %%{time_total}\n"
rem log 儲存的地方
set logfile="C:\log\%CURRENT_DATE%_network_info_%%I.txt"
rem 由於多個網站 所以可以去檔案下讀取
rem tw.yahoo.com
rem www.google.com
rem www.hinet.net

for /f "tokens=*" %%I IN (C:\domain.txt) do (


set curl_output=%command% %var% https://%%I

    echo *** URL Scan Start. *** >> %logfile%
    echo --------------------------------------------------------- >> %logfile%
    echo %CURRENT_DATE%-%CURRENT_TIME%
    echo Started: %CURRENT_DATE%-%CURRENT_TIME% >> %logfile%
    echo %%I >> %logfile%
    %curl_output% >> %logfile%
    rem %curl_output%
    echo                                                         - >> %logfile%
    echo Completed: %date% %time% >> %logfile%
    echo --------------------------------------------------------- >> %logfile%
    echo %%I
    echo *** URL Scan Complete. *** >> %logfile%
    echo --------------------------------------------------------- >> %logfile%

)

############################ bat script end ####################################
 上面只要貼到文字編輯後 儲存成 bat檔案即可 然後使用 windows 上的工作排成器 就可以每分鐘收集囉!

2017年7月19日 星期三

Rotueros web Proxy 要使用客製化頁面

web Proxy 要使用客製化頁面 一定要先執行
[admin@MikroTik] > /ip proxy reset-html Current html pages will be lost! Reset anyway? [y/N] y
然後再確定是否有出現 檔案目錄
[admin@Router-ISP4] > /file print
.......
5 webproxy directory jul/19/2017 14:14:16
6 webproxy/error.html .html file 569 jul/19/2017 14:20:48
.......
就可以編輯 網頁囉
[admin@Router-ISP4] > /file edit webproxy/error.html contents


參考資料
https://wiki.mikrotik.com/wiki/How_to_make_transparent_web_proxy#Customizing_error_pages

2017年5月11日 星期四

SRX 上抓取封包

如果遇到 SRX上要抓取封包 不會用 tcpdump 怎辦? 可以使用下列指令來抓封包看 # 設定 抓取名稱為 tcpdumpacktrace set security flow tcpdumpacktrace file flow-trace set security flow tcpdumpacktrace flag basic-datapath set security flow tcpdumpacktrace packet-filter f0 source-prefix 192.168.1.129/32 set security flow tcpdumpacktrace packet-filter f0 destination-prefix 192.168.1.51/32 # 確認 修改設定範圍 show | compare # 確認執行設定 commit and-quit # 查看封包 srx240> show configuration security flow srx240> show log flow-trace # # once you have completed this you can turn off the tcpdumpacktrace as follows # #刪除 抓取封包設定 delete security flow tcpdumpacktrace # 確認 修改設定範圍 show | compare # 確認執行設定 commit